Hardeman Motorsport - motorsport parts and diff specialist

Tearing front suspension mount bearing

For all your questions, problems and DIY stories
Post Reply
User avatar
l3v4rt
Upcoming E21 fanatic
Posts: 40
Joined: Fri Apr 29, 2016 9:31 pm
My E21(s): '80 316 manual - Alpinweiss

Tearing front suspension mount bearing

Post by l3v4rt » Wed May 15, 2019 5:08 pm

Hi everyone!

I had my e21 on Bilstein B8 and H&R -35mm kit for about two years now and I had my previous top suspension mount tearing so I bought new ones. After about 400km I've started to see some tear and after about 2000km the drivers side loks really, really bad. I've seen photos of new ones on wallothnnesch and even those look bad on photos, I ordered new ones and checked the min the store and the rubber was old and had cracks.

So - what are the solutions? I will fit PU bushing everywhere and I'd like to sort this out. I was thinking maybe using camberplates? I've seen SilverProject sells them for abour 100€ and a few versions like GroundControl, CA Tuned. Any reccomendations? I'm from central europe so I don't fancy spending more on shipping and tax than plates from US. Thanks!



User avatar
Jeroen
Site Admin
Posts: 25840
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: Tearing front suspension mount bearing

Post by Jeroen » Wed May 15, 2019 9:57 pm

Sounds like you got some antique top mounts, no other suspension parts are going to prevent that from happening. However, something else may have contributed and that's the sequence of fitting all the o-rings on both sides of the bearings. With the entire strut assembled the top bearing should turn freely. If not, the sequence is incorrect and you're turning on the bushing instead of the bearing, which can also cause weat. Personally I don't see PU as a solution to anything on a street car.
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

User avatar
l3v4rt
Upcoming E21 fanatic
Posts: 40
Joined: Fri Apr 29, 2016 9:31 pm
My E21(s): '80 316 manual - Alpinweiss

Re: Tearing front suspension mount bearing

Post by l3v4rt » Sun May 19, 2019 10:33 am

Hi Jeroen! Thnks for the reply. I have bought KYB top mount with bearing and it started tearing really fast. I'll post the picture but the part was new and this is the current state after I thin kabout 2000km. In the store we ordered Meyle part as well and the rubber was visably bad quallity. Do you reccomend going to the officieal dealer or what? I don't want camberplates with ballbearing and having it cracking. I'll post some pics of the state.

Image

Image

User avatar
Jeroen
Site Admin
Posts: 25840
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: Tearing front suspension mount bearing

Post by Jeroen » Sun May 19, 2019 10:53 pm

Meyle is the worst rubbish available on the market today, I would definitely recommend OEM from the dealer. And make sure it's spinning freely!
Regards/groeten, Jeroen

We want your contributions in our E21 Facebook Group! Join, like, post & share!

User avatar
l3v4rt
Upcoming E21 fanatic
Posts: 40
Joined: Fri Apr 29, 2016 9:31 pm
My E21(s): '80 316 manual - Alpinweiss

Re: Tearing front suspension mount bearing

Post by l3v4rt » Tue May 21, 2019 10:37 am

Thanks! I'm planning on buying from the BMW official dealer and make sure to keep the reciept so I can use warranty if it tears like these.

Post Reply