BertjeConti's daily - '96 523iA [E39]

Voor alles niet E21 gerelateerd
Post Reply
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

De 523i zaagt

Het was alweer veel te lang geleden, maar nu zijn we eindelijk weer eens met de Titan achter de E39 op reis, het is voor het eerst dat we met de combinatie op vakantie zijn sinds de motorwissel in 2022.
Dus nu pas kan ik de motor echt goed beoordelen, en er is toch iets wat mij niet in orde lijkt.

Onder last zaagt de motor namelijk, wat ik hiermee bedoel is dat de motor bij constant gaspedaal golvend meer/minder vermogen levert in een 1 seconde kadans. Je ziet het ook duidelijk aan de verbruiksmeter, die schommelt dan namelijk. Des te meer vermogen er gevraagd wordt, des te duidelijker is het waarneembaar, dus vooral bij klimmen in de heuvels.
Het treed vooral op tussen de 2500 en 3500 toeren, daarboven lijkt het te vervagen en is het vermogen volledig beschikbaar.
Wel vervelend want veruit de meeste tijd draait de motor tussen de 2500 en 3000 toeren en is het fenomeen dus waarneembaar.

Bij WOT zie je de verbruiksmeter schommelen tussen 18 en 20 L/100km en voel en hoor je ook duidelijke vermogen toename en afname in de 1 seconde kadans.
Bij normaal solo gebruik in Nederland is dit fenomeen niet waarneembaar, tenminste nooit iets van gemerkt.

Mijn verdacht gaat richting een defecte Vanos, die lijkt in te komen en weer af valt. Misschien wel door versleten afdichtringen waardoor bij het inkomen de oliedruk wegzakt en de vanos weer terug schuift, oliedruk neemt weer toe en vanos probeert weer in te komen.
Waar de Vanos 2 jaar terug nog prima leek te werken, verdenk ik hem nu toch sterk, eerlijk gezegd mist de motor ook echt wel wat vermogen onderin. Bij echt klimwerk boven de 4000rpm gaat i echter als de brandweer....

Verder 0,0 problemen, dus lekker vakantie vieren ergens in Frankrijk.


Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
uwbuurman
E21 VIP
E21 VIP
Posts: 18768
Joined: Fri Jun 12, 2009 4:49 pm
My E21(s): 1978 type 1 323i 5speed dogleg Polaris
Location: Ljouwert

Re: BertjeConti's daily - '96 523iA [E39]

Post by uwbuurman »

Hmmm, vervelend. Die Vanos hebbje eerder nog niet preventief gereviseerd, dan?

Fijne vakantie!!
It's the man next door!

1978 BMW 323i
1980 BMW 528i maior restitutio
1987 BMW 325iA cabriolet
2015 BMW 320dA touring xDrive High Executive ///Msport
2016 BMW 420dA Gran Coupé
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Thanks,

Nee, niks aan gedaan, wel op het vorige blok, dus heb een verse vanos op stock.
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
Jeroen
Site Admin
Posts: 29414
Joined: Tue Sep 14, 2004 12:23 pm
My E21(s): '81 323i Baur
Location: The Netherlands
Contact:

Re: BertjeConti's daily - '96 523iA [E39]

Post by Jeroen »

Stationair is het doorgaans een vacuumprobleem, maar onder last zou het idd weleens je Vanos kunnen zijn. Gelukkig te overzien qua werk!
Regards/groeten, Jeroen
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Inmiddels weer terug in het natte kikkerland, gelukkig zonder verdere problemen.

Eerste diagnose is gedaan, ik wilde zeker weten dat de Vanos klep wel juist en niet intermittend aangestuurd wordt door de DME, en of de klep uberhaupt wel werkt.
Hiervoor een kabeltje gemaakt dat tussen de stekker van de Vanos klep gestoken kan worden met daaraan een lang kabeltje met LED lampje dat tot in de bestuurdersruimte reikt.
Gaat het lampje aan, dan wordt de Vanos klep aangestuurd, mooi te analyseren terwijl ik rondrijdt.

Maar eerst de werking van de klep getest, als je tijdens stationaire loop de Vanos inschakelt, dan valt het toerental terug en begint de motor te haperen alsof hij flink valse lucht krijgt, hiermee is in ieder geval duidelijk dat de klep nog werkt en de Vanos aan stuurt.

Dan onderweg de Vanos aansturing bekijken, zodra je gas geeft en RPM>1500 schakelt hij in en blijft in tot 5000 RPM.
Laat je cruisend het gas los, dan schakelt hij ook meteen weer uit, de Vanos wordt dus aangestuurd op 2 parameters:
- minimaal ingedrukt gaspedaal
- RPM 1500-5000

DME en Vanos aansturing zijn dus ook in orde, ook DME even uitgelezen, wellicht was een haperende nokkenas sensor de boosdoener, maar geen errors.

Het "zagend" effect is op een vlakke weg zonder extra last moeilijk waar te nemen, maar door in 4e versnelling vanaf 30km/u te accelereren is het wel waarneembaar.

Volgende stap is het vervangen van de Vanos unit zelf, vers gereviseerde unit ligt al klaar, pakkingenset is onderweg.
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Na gisteren weer eens lekker een dag rally gereden te hebben, vanmiddag eindelijk tijd en zin om de Vanos unit te vervangen, komt goed uit want ook de olieleiding moest nog vervangen worden, die erop zat is zo lek als een mandje:

Om de olieleiding achterop het oliehuis te kunnen de-en-monteren dient er flink wat ruimte gemaakt te worden, luchtfilterhuis met MAF, SB reservoir en purge klep dienen verwijderd cq aan de kant geschoven te worden. Bijkomend voordeel is dat nu ook makkelijk de blokkeerpin voor de krukas geplaatst kan worden.

Na verwijderen kleppendeksel laat zich een typisch bronskleurig nokkenas assemble zien, wel met best wel wat koolaanslag.
Meeste koolaanslag zit echter tegen het deksel zelf, fijn in de vele hoekjes. Als de krukas op OT staat en geblokkeerd is laten de blokkeergereedschappen voor de nokkenassen zich ook erop schuiven zonder problemen en sluiten mooi aan op de kop, de motor stond dus exact op "tijd".

Image

Hier de olieleiding die voor een behoorlijke smeerboel zorgde tot achteraan onderaan het blok en bak aan toe:
Image

Bij het verwijderen van luchtfilterhuis toonde zich een nieuw probleempje, de luchtslang naar de stationaire luchtschuif is gebarsten aan de kant van de rubber balg. Die is nu provisorisch gerepareerd maar wordt natuurlijk zsm vervangen.

Vanos zelf liet zich kinderlijk eenvoudig verwijderen en de nieuwe plaatsen was ook een makkie, als je maar de juiste toolset hebt.

Image

Hier zit het alweer in elkaar en klaar voor het deksel met uiteraard nieuwe pakkingen.
Image

Dat de seals in de oude vanos unit niet meer goed afdichten was ook snel getest, bij in en uit bewegen van de vanos zuiger bouwt zich amper nog maar druk op als je de olieaansluiting met je duim dicht houd, de seals zijn zelfs zo ver weg dat als je de vanos unit plat op tafel legt en de zuiger omhoog trekt, deze vanzelf weer terug valt als je hem los laat.
Bij de gereviseerde vanos unit was volledig indrukken met de hand niet mogelijk met afgesloten olieaansluiting, er bouwde zich teveel druk op.

Al met al een klusje van een dikke 3 uurtjes waarbij het schoonmaken van het kleppendeksel veruit de grootste en smerigste klus was.
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
uwbuurman
E21 VIP
E21 VIP
Posts: 18768
Joined: Fri Jun 12, 2009 4:49 pm
My E21(s): 1978 type 1 323i 5speed dogleg Polaris
Location: Ljouwert

Re: BertjeConti's daily - '96 523iA [E39]

Post by uwbuurman »

En de grote vraag is nu, merk je verschil?? Lekker gewerkt in ieder geval.
It's the man next door!

1978 BMW 323i
1980 BMW 528i maior restitutio
1987 BMW 325iA cabriolet
2015 BMW 320dA touring xDrive High Executive ///Msport
2016 BMW 420dA Gran Coupé
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

uwbuurman wrote: Sun Jun 02, 2024 9:30 pm En de grote vraag is nu, merk je verschil?? Lekker gewerkt in ieder geval.
Tsja inderdaad merk ik verschil?
In eerste instantie zeg ik JA, er is direct meer koppel aanwezig.

Maar bij wat langer testen lijkt het gezaag nog steeds aanwezig, alhoewel het heel moeilijk waarneembaar is.

Volgend weekend gaan we naar de Eifel (wel solo), dan eens kijken hoe het zich gedraagt.
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Terug van een weekendje Eifel wat uiteindelijk niet zo afgelopen is als gehoopt.

Vrijdag heenreis geen problemen, maar wel kunnen constateren dat het gezaag nog steeds aanwezig is, dit merk je dus best goed als er op constante snelheid geklommen moet worden, vooral op de snelweg dus. Eigenlijk best wel irritant. Maar verder loopt de 523i prima, vermogen onderin valt wat tegen, maar eenmaal boven de 3000 komt i echt wel los. En vooral solo echt geen zuipert, zeker op autobahn snelheden rijdt i gewoon 8L/100km.

Maar goed, vandaag (maandag) werd het drama. Wilde niet direct aan slaan, en na een paar kilometer in een afdaling hield i er gewoon mee op. Gelukkig wel weer opnieuw te starten, maar er was totaal geen vermogen beschikbaar.
Daarbij ging ook nog de olie niveau lamp branden in diezelfde afdaling. Lekker begin met nog een kleine 300km te gaan.
Bij het eerst beste tankstation gestopt om de olie te peilen, die stond op minimum, dus er maar een half litertje bij gedaan.
Daarmee was de waarschuwingslamp uit, maar nog steeds geen vermogen.
Stop en go door Trier helemaal spannend, want ook de stationairloop was onregelmatig, en dreigde regelmatig af te slaan.
Eenmaal op de snelweg was het moeizaam op snelheid komen, en dat was eigenlijk alleen in sportstand of met handmatig schakelen doenbaar om hoger in de toeren te komen, want dan was er wel vermogen.
Er is dus iets goed mis met één of andere sensor.
Het systeem lijkt in noodloop te lopen, waardoor er dus ook geen vanos beschikbaar is.
Zo zijn we rustig aan naar huis geprutteld, met een beetje geduld waren gewone snelweg snelheden wel haalbaar, en de verbruiksmeter gaf ook geen hoge waarden aan.
Mechanisch is er niks aan de hand, dat wist ik zeker.

Eenmaal thuis eerst afkoelen en dan even uitlezen:
Er was één error: "crank position sensor"

Dat verklaart een hoop natuurlijk.

Na reset van deze error kwam die niet meer terug, en snel even een proef rondje leerde dat het vermogen weer volledig beschikbaar was.
Blijft natuurlijk de vraag waarom die cps sensor in storing gegaan is, en het nu weer doet ?????

Ik weet nu zeker dat de Vanos altijd wel gewerkt heeft, want zonder (in noodloop dus) is er echt niks van vermogen onderin aanwezig.
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
uwbuurman
E21 VIP
E21 VIP
Posts: 18768
Joined: Fri Jun 12, 2009 4:49 pm
My E21(s): 1978 type 1 323i 5speed dogleg Polaris
Location: Ljouwert

Re: BertjeConti's daily - '96 523iA [E39]

Post by uwbuurman »

Ai, dat is vervelend! Gelukkig thuisgekomen. Verbruikt 'ie veel olie? Snel nieuwe sensor en weer door, lijkt me?
It's the man next door!

1978 BMW 323i
1980 BMW 528i maior restitutio
1987 BMW 325iA cabriolet
2015 BMW 320dA touring xDrive High Executive ///Msport
2016 BMW 420dA Gran Coupé
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Ik heb nog een OEM sensor liggen, maar wil eerst weten waarom die storing ontstaan is en nu weer weg is. Deze week eens kijken of hij weg blijft en of ik iets kan vinden.
Olieverbruik, half litertje op een paar duizend kilometer zoiets.
Ik schat zo een liter olie per 5000 km.
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Tsja, en het gezaag probleem, daar weet ik echt geen raad mee.
Ik zal er eerst achter moeten komen wat er varieert, dat kan lucht, of brandstof of ontstekings tijdstip zijn. Heb echt geen idee.

Oh ja, zelfs in de noodloop vandaag was het gezaag aanwezig, misschien brengt dat mij nog op een idee ?!?!?
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
Wilmo
E21 Mad
Posts: 1964
Joined: Thu Jun 30, 2011 8:35 pm

Re: BertjeConti's daily - '96 523iA [E39]

Post by Wilmo »

Balen dat het niet vanzelf ging! Maar kun je de brandstofdruk uitlezen tijdens het rijden? En de lambdasondes? MAF? Wat gaat er tijdens de noodloop nog meer uit? Lambda closed-loop misschien?
User avatar
BertjeConti
E21 Mad
Posts: 3037
Joined: Mon Nov 04, 2013 9:49 pm
My E21(s): E12 520-6
Location: nederland , Weert

Re: BertjeConti's daily - '96 523iA [E39]

Post by BertjeConti »

Wilmo wrote: Mon Jun 17, 2024 10:41 pm Balen dat het niet vanzelf ging! Maar kun je de brandstofdruk uitlezen tijdens het rijden? En de lambdasondes? MAF? Wat gaat er tijdens de noodloop nog meer uit? Lambda closed-loop misschien?
Brandstofdruk uitlezen zou wel mogelijk moeten zijn, maar daar moet dan wel voor geknutseld worden. Lijkt mij niet aannemelijk dat een brandstofdruk probleem voor het "zagend" vermogen probleem verantwoordelijk is, daarvoor is het te constant kwa timing. Het zagend effect is er namelijk in een zeer getimde aan/uit kadans van 2 seconden.

Hij ging nu dus in de noodloop op een 'foutief' cps signaal. Timing van injectie en ontsteking moet dan berekend worden aan de hand van het camshaft position signal, en die geeft maar 1 puls per omwenteling van de nokkenas, best knap dus dat het nog aardig loopt. Uiteraard kan de vanos dan niet geactiveerd worden, want dan gaat het camshaft signaal zeker uit de pas lopen.

Er zijn verschillende noodloop situaties mogelijk, bijvoorbeeld bij een incorrect MAF signaal wordt aan de hand van TPS, toerental en een tabel een injectie waarde berekend. Of als de CLT defect is wordt er uit gegaan van 50 graden clt.

Een tijdje terug had ik een error op de camshaft sensor (goedkope replica), daar merk je bijna niks van, bij een defect aan de camshaft sensor gaat de ontsteking in "wasted spark" mode, de rest blijft normaal doorwerken.

Dit opschrijvend doet mij er wel aan herinneren dat er dus een replica camshaft op deze motor zat, misschien ook wel het geval bij de CPS, wie weet......
Image
Megasquirted '77 E12 520-6

Aspen Silver '96 E39 523i
Wilmo
E21 Mad
Posts: 1964
Joined: Thu Jun 30, 2011 8:35 pm

Re: BertjeConti's daily - '96 523iA [E39]

Post by Wilmo »

Zolang je dus niets uit kunt lezen, blijft het gissen. Een pomp die een druk opbouwt en dan ergens doorslaat, waarna die weer druk opbouwt kun je in elk geval zien. Mits je dus iets van druk uit die CPU kunt halen. Of lambda, of überhaupt iets van brandstroftrim.

Of beide sensoren eens vernieuwen/veranderen.
Post Reply